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Important Changes to Previous Release

Overall-Quality:
… describes a heuristic measure of reliability and quality of a data sample (3D particles and
velocities). It relates the detected match count to the optimal number of matches. Value range is
[0…1] for un-constraint to strictly constraint. The particles displayed in ‘Positions’ view are colored
by their overall-quality [red…green]. Use visualization slider ‘Min. overall-quality’ in ‘Positions’
parameter tab, to filter visualization by overall-quality.
The other filters still apply to post-processing. Nevertheless, using overall-quality filter their
default values are adequate in most cases.

Cancel Active Estimation:
Canceling the active estimation won’t invalidate the estimation framework. The active estimation
is stopped and the associated data is deleted. The estimation can be continued, with altered
parameters if applicable, from the same time index.

Data Export:
• VTK output for velocity grids now contains the grids ‘density’ (number of measurements used

for respective cell) in addition to velocities.
• Overall-Quality for each measurement is logged to .vels and .tracks files. FORMAT CHANGED

see Result Data Export



Light Field Cameras
Copyright © 2014 by Raytrix GmbH, Germany

www.raytrix.de3D

4

Important Changes to Previous Release

Background Image:
• Computation of background image is now independent on usage of processed image. The

same background can be used for processed and non-processed image input.
• The image index range for background computation is now independent of the estimations

start index. I.e. in PIV mode both bg images estimated in range 2…31 are applied correctly to
first/second double shoot image in estimation starting at index 1.

Grid Parameters:
• ‘Smoothing Factor’ is given relative to cell size. If ==0 no smoothing is applied (plain average in

cell). For ==1 measurements with ‘cell size’ distance to respective cell are comprised weighted
depending on distance.

• ‘Min. Overall-Quality’ applies threshold filter to input data. Measurements with overall-quality
below threshold are discarded in grid computation. Recommended 0.3 to 0.4 in most cases.

• ‘Auto Set’ button now copies all filter settings (max re-projection error etc.) from GUI to
parameter dialog

Visualization:
• Re-centering by right-click. Right-click a particle in 3D particle view centers ‘Positions’ and

‘Velocities’ view to clicked particle.
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Graphical User Interface
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Graphical User Interface Layout

Tool strip controls
Basic controls for system setup and estimation/visualization process

Image visualization
Visualization of images, lens calibration and detected particles

3D visualization
Visualization of reconstructed particles and flow/track estimations.
Divided into a pure particle “Position” and a “Movement” visualization.

Image Progress
Progress information for image number and estimation stages (2D / 3D).

Configuration tabs
Controls for configuration of estimation and visualization.
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Graphical User Interface Layout

Image visualization

Tool strip controls

Progress information Configuration tabs

3D visualization
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Graphical User Interface Tool strip controls

Open Sequence
Load a ray-sequence file from disk. Same as drag-and-drop file to GUI.

Configure
Opens Configuration Dialog. Allows for setting basic system properties.
A configuration file can be loaded via “File” menu bar or drag-and-drop.

Initialize
Initializes framework after successful configuration and sequence load.
Enables estimation and visualization. Fixes specific parameters such as 
camera type etc.

Reset
Resets system after initialization and discards ALL gathered data. The 
configurations (system, visualization, grid) remain and can be re-used.
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Graphical User Interface Tool strip controls

Play
Starts continuous estimation for the whole image sequence. Selected 
visualization types (except for grid) are updated with each processed image.

Next
Starts estimation for the next image. Enters “Pause” state afterwards.

Pause
Stops a continuous estimation at next image. Continue estimation using 
Play/Next.

Cancel
Cancels active estimation. Triggers first-chance stop of estimation threads.
Data of active time index is cleared and state of previously estimated time 
index is restored. Continue estimation at canceled time index using 
Play/Next.
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Graphical User Interface Tool strip controls

Single Image
Activates the visualization of a single image/time-step. 2D visualization
displays detected particles in actual image, 3D visualization displays particle
positions and position increments.

Single Track
Displays a single track (position history for a single particle) in “Movement”

All Tracks
As above for all tracked particles at once.

Grid
Visualize an adjusted velocity field as regular grid or flow lines. See GRID

Clear
Clears the visualization and cancels updates until an other mode is selected
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Workflow



Light Field Cameras
Copyright © 2014 by Raytrix GmbH, Germany

www.raytrix.de3D

12

Workflow
1. Create/load system configuration

2. Open image sequence

3. Initialize system

4. Estimation
• Continuously, all images successively
• Stepwise, trigger each estimation separately and visualize results

5. Result visualization
• Choose visualization mode
• Compute/view grid if applicable

6. Store results to file

Use “Reset” tool strip button to clean up old estimation and restart at 1 or 3.
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Workflow Step 1 : Algorithm Configuration

Load existing configuration:
• From menu “File->Load Configuration”
• Using drag-and-drop
• Open configuration dialog (ToolStrip “Configure”) and click “Load Config”

Creating a new configuration :
1. Open configuration dialog via ToolStrip “Configure”
2. Setup camera type and either

• Set “Manual Calibration” to false if metric calibration is available in ray-sequence
• Set “Focal length” and “Focal distance” of actual camera setup

3. Set estimation parameters (see following pages)
4. Select working directory. Click text box right of “Working directory”
5. Select image sequence file. Click text box right of “Sequence File”

 Alternatively use “File->Open Sequence” or drag-and-drop in main window

For re-use store configuration from configuration dialog “Save Config”.
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Important Parameters

For most setups only a few parameters have to be adopted to the image properties. For a more
detailed description see next section.

• Calibration: without metric calibration at least Camera Type has to be set
• Metric calibration available in ray-sequence? => set “Manual Calibration” to “false”
• Else set “Focal distance” and “Focal length” and set “Manual Calibration” to “true”

• Focal distance = distance to most far focus plane, i.e. backside of scene

• Density of particles: Start with medium and set to high if 3D processing is slow.

• Particle brightness minimum: Set to avoid high runtime of 2D processing.
• Use “View->Context Info” and click image in “Image” visualization to get information on image

brightness at pixel of “darkest” particle

• Bounding box : Exclude areas not to be reconstructed, to reduce processing time.
• Use “View->Context Info” to determine pixel coordinates of bounding box

• Start/Stop image : Select sub sequence to process.
IMPORTANT: For PIV mode the start image index MUST be the first image of a double

shoot! Please validate this for each sequence in RxLive

Workflow Step 1 : Algorithm Configuration
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After the systems configuration and initialization are applied, the system is in 
‘Paused’ state at first image of selected subsequence. The estimation can be…

• Started by
• Play: starts continuously estimation of succeeding images.
• Step: starts single estimation for NEXT image.

• Stopped by
• Pause: waits for active estimation to be completed. Pauses the system to 

visualize the respective results.
• Cancel: discards the active estimation. Pauses the system this time index. No 

data is displayed since estimation was canceled. Next call to Step or Play
continues with canceled time index.

• Full Reset
• For deleting ALL estimations and temporary data. Only configuration and 

parameter settings will be kept.

Workflow Step 2 : Estimation
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The state-flow for estimating sequences for indices N=start…stop is controlled as
displayed below. Except for canceled estimations the visualized time index is as of
‘Paused N’.
After canceling an estimation no data is displayed until the next successful
estimation using Step or Play.

Workflow Step 2 : Estimation

Paused N Estimating N+1
Play/Step

Delete N+1

[Play]
Pause / [Step]

N → N+1

Cancel ?

YES

NO
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Whenever the system has entered ‘Paused’ state, the visualization type and
parameters can be adopted. If an estimation is in progress, data is displayed
and updated for each completed time index but filter parameters can’t be
altered.

Two view contexts are available for visualization of data (see GUI Layout). A 2D
context displaying the active image and gathered 2D particle data. A 3D
context for visualizing 3D particles, velocity vectors and grid structures.

For post-processing of data various filters can be applied. In especially certain
thresholds can be used to discard particles, that are assumed to be unreliable
or imprecise. See section Visualization for more details.

Workflow Step 3 : Visualization
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Assuming a constant flow, a series of estimations can be used, to estimate a time-
averaged velocity field. For this, a regular grid is created and its cells are ‘filled’ with the
observed particle velocity. Using a weighted average filter, the noise in velocity
estimation (especially z-axis) can be reduced significantly.

The Grid is computed using all measurements, that are not invalidated by the constraint
filters (min. overall-quality, max. velocity etc.). Using the cell count in each dimension the
spatial resolution can be altered. Additionally the ‘Smoothing Factor’ controls the size of
smoothing factor. For =0 no smoothing is applied. Smoothing is applied in z-direction
exclusively!

Flowlines represent simulated particle movements. For a given number of particles
samples are distributed equally in the grid volume. Each sample is propagated through
the velocity field according to direction and magnitude of local velocities. For an intuitive
representation of the velocity field an animation simulates moving particles traveling the
flowline trajectories.

Call the grid configuration dialog “Configure Grid” in the movement parameter tab to
parametrize and compute grids/flowlines. See grid parameters for a detailed description.

Workflow Step 4 : Grid Computation
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Algorithm Parameters
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System parameters – stage 2D/3D : applies to resp. stage in progress bar
• Calibration:

• Manual Calibration: if false, calibration parameters are read from image
sequence. CAUTION: if sequence is not calibrated, estimation will be invalid.

• Camera Type: determines additional calibration information internally
• Focal Length/Distance: for metrical reconstruction without calibrated image

sequence. Not all combinations are valid in used thin lens equations. Focal
distance has to be at least 4x focal length.

• Estimation (green: can be altered in “Estimation” tab after system initialization)

• Background brightness avg.: 2D stage. Approximate brightness of
background scene [0…255]. Allows for more stable particle detection for
scenes with bright backgrounds.

• Density of particles: 3D stage. use LOW if only <1 particle per lens is
observable (at minimum particle brightness). Use HIGH if multiple particles
are visible in each lens. – tradeoff between computational effort and
amount of uniquely estimated 3D particles

Algorithm Parameters
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Algorithm Parameters

• Estimation (green : can be altered after system initialization)

• Max. epipolar distance: 3D stage. 2D particles combined to a single 3D
particle have to fulfill epipolar constraints. Higher values allow for more but
also more unreliable matches. Recommended setting is 0.5 to 1.0 pixels

• Particle brightness minimum: 2D stage. Provides a threshold to brightness
of detected particles [0…255]. Particles with lower brightness won’t be
considered (not rejected but not detected!). Low values can cause image
noise to be detected as particles. High values can result in combining
particle groups to a single particle!

• Radius Min/Max: 2D stage. Smaller/larger particles are rejected before time
tracking and depth matching are applied. Given in pixel.

• Time Matcher Type: 2D stage. VISUAL uses the particle size and brightness
as similarity measure. DISTANCE uses only the minimal movement
constraint. The latter is especially dedicated to double-shot images or very
slow movements.



Light Field Cameras
Copyright © 2014 by Raytrix GmbH, Germany

www.raytrix.de3D

22

Algorithm Parameters

• Estimation

• Lens Types: 2D stage. The different lens types are treated differently during
estimation. Mostly type 2 and 3 will be most useful for reconstruction.

• Number of Threads: … to be used for processing in 2D and 3D. Speedup for
multi-core systems in case of high particle count.

• PIV mode: activates double-shot mode. Time tracking is applied only
between succeeding image pairs (1<->2; 3<->4 etc.).

• Particles per lens limit: skip lenses where more particles are detected to
avoid high runtime 3D estimation

• Image Properties

• The Bounding Box describes an area within the image that is to be analyzed.
Use “View -> Context Info” window to determine correct range.

• Invert image brightness: transforms image pixel-wise to 255-brightness. Use
to detect dark particles on bright background (e.g. backlight illumination).
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Algorithm Parameters

• Misc

• Enable Visualization: When set to false, NO visualizations will be available. Allows for
processing long sequences by fixing memory usage. ‘Auto Set’ feature in grid dialog
will NOT be available.

• Start/Stop image: give index range of images in ray sequence to process. Progress
information displays image index, progress bar relative progress in [start…stop].

IMPORTANT: For PIV mode the start image index MUST be the first image of a
double shoot! Please validate this for each sequence in RxLive

• Time Delta: Time in seconds between successive images. In PIV mode the delay in a
double shoot, inverse of recording FPS else.

• Working Directory: Click text slot to give the directory for temporary data and default
directory. Avoid network devices since filesystem re-connections can cause swap data
to be lost.

• Ray-Sequence File: If no file is given, please set afterwards using “File->Open
Sequence” or drag-and-drop to GUI.
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Algorithm Parameters

• Background Image

• For scenes with a static background a “BG Image” can be determined, to
reduce the backgrounds impact on particle detection.

• Assumes static a background and it’s visibility in each pixel in at least one
image. (not necessarily all in the same image)

• For PIV mode two images are computed. (for first and second shot)

• Create by
1. Click tool strip “Compute BG Image”
2. Select image index range and brightness tolerance (= noise in background)
3. Start computation

The background image[s] can be exported as ray-sequence via “File->Export BG
Image”. It can be imported for later sessions (via “File->Import BG Image”).
The exported sequence can also be used with RxLive for additional processing.
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Algorithm Parameters

• Processed Image

• To improve particle detection quality, the raw image can be normalized with
the ray-sequence’s gray image.
• Toggled by the “Use Processed Image?” checkbox in “Estimation” tab

• Normalization reduces brightness decrease at lens boarders and, by this,
improves particle detection.

• Since the normalization amplifies image noise close to lens boarders, the
grey image’s quality is crucial.
 Switch between non-/normalized images to check image quality and

estimation stability

NOTE:
The particle brightness and the scene’s background will change. Be sure to
adopt the respective algorithm parameters accordingly.
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Algorithm Parameters: Grid Adjustment

Grid computation and visualization

• Computes interpolated/averaged displacements for a regular grid using a series 
of estimations (assuming a constant flow)

• Visualization as

 Regular grid : displacements at equidistant 3D positions

 Flowlines : similar to “All Tracks” using synthetically generated tracks. 3D 
particles are generated and propagated using interpolated grid velocities.

• In combination with “Enable Animation” flowlines provide an intuitive 
visualization of the overall movement simulating a high particle density.

In addition to the position and displacement constraints certain grid properties can 
be configured. See next page.
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Algorithm Parameters: Grid Adjustment

De-/activate the grid configuration dialog from
“View->Grid Configuration” or “Configure Grid” button 
in “Movement” tab.

“Auto Set” : generates a guess for grid configuration 
using the visualization parameters.

“Apply” : triggers computation/update of grid/flowlines

“Done” : as above and closes configuration dialog

“Cancel” : discards all changes and closes dialog
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Algorithm Parameters: Grid Adjustment

Computation parameters

“Visualization Type” : Either Grid or Flowlines. The former computes the regular 
velocity field. The latter updates the grid (if needed) and 
visualizes simulated particle tracks.
determine plain average in cell.

“Minimum density” :  Threshold for quality of information per cell. If fewer input 
samples (estimated velocities) are available for a certain cell, 
the respective velocity is set to 0 (invalidated).

“Smoothing factor” : Size of smoothing area in “Grid Step Sizes”. Corresponds to the 
standard deviation of a Gaussian smoothing kernel. For sf=0 
no smoothing. For sf=1 the filter radius is ½ + 1 cell and 
measurements outside the cell (distance > ½ cell) are weighted 
by distance.
Smoothing is applied in z-direction exclusively!
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Algorithm Parameters: Grid Adjustment

Data Constraints (same as visualization constraints see Particle analysis)

Velocity measurements violating any of the thresholds are assumed invalid and are not used for 
grid computation.

“Max. velocity” : Upper limit for magnitude of velocity measurements. 

“Min Overall-Quality” : Lower limit for overall quality for involved 3D particles.

“Min Baseline-Angle” : Lower limit for relative positions of involved lenses. In [rad]
MIN = 0      : Lenses are allowed to lie on a line (instable depth matching)
MAX = π/2 : At least 3 lenses form a right triangle (more stable but less 

often)

“Max. Re-projection Error” : Upper limit for re-projection quality of involved 3D 
particles.

“Min Depth Matches” : Lower limit for number of 2D particles used to estimate each 
3D particle involved in velocity estimation.
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Algorithm Parameters: Grid Adjustment

Flowline Animation Parameters

Grid parameters applicable for “Visualization type : FLOWLINES”. Control visual appearance of 
simulated particle movement on flowline trajectories. No grid re-computation needed when 
parameters are changed.

“Min. Neighbor Cells” : For flowline generation velocities are interpolated from grid. 
Each position in flowline trajectory needs at least the given number of 
interpolation source cells.

“Trail Length Scale” : Scale factor for ‘length’ of animated particles.

“Velocity Scale” : Scale for speed of animated particles on flowline trajectory.

“Particle Density Scale” : Scale for number of particles animated on a single flowline.
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Algorithm Parameters: Grid Adjustment

Flowline Parameters

Grid parameters applicable for “Visualization type : FLOWLINES”. Control visual appearance of 
simulated particle movement on flowline trajectories.

“Max. FlowLine Length” : Maximal length (time steps) of flowlines. Long tracks are
able to resolve areas with low velocities.

“Min. FlowLine Length” : minimal length (time steps) of flowlines. Short tracks are
able to resolve areas with sparse grid occupancy.

“Flowline Count” : Total number of flowlines. High track count is more suitable for 
animated visualization (“Enable Animation” in movement configuration t
ab) but increases computational visualization effort.

“Line Step Scale” : Scales estimated velocity for generation of tracks. In combination 
with min/max length the spatial resolution of flowlines can be controlled.
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Algorithm Parameters: Grid Adjustment

Post Processing

“Velocity Clamp” minimum [0] and maximum [1] cutoff for velocities in each axis direction.
• E.g. allows for visualization of slices of the velocity field.
• In combination with flowlines sliced animations can be generated.

Spatial Properties

“Grid Bounds” minimum [0] and maximum [1] of grids bounding box. The minima define the 
bottom-leftmost-back cell position. The maxima the top-rightmost-front cell position.

“Grid Cells”  define the number of cells in each axis direction. A grid with cell count x=20, y=15, 
z=10 cells has a total of 20*15*10 = 3000 cells.

“Grid Step Size” [read only] size of a cell in x/y/z axis. That is (max-min)/cellCount



Light Field Cameras
Copyright © 2014 by Raytrix GmbH, Germany

www.raytrix.de3D

33

Visualization
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Visualization

Image – all modes

1. Calibration of lens grid : Lens area (large colored circles). Lenses are colored 
by lens type.

2. Detected particles in each lens. Circles mark the estimated particle radius. 
Green particles are considered valid, red invalid (too large, out of lens area…)

3. Re-projection (see next page). Visualizes estimation for selected 3D particle.
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Visualization

Position – all modes

• Visualizes estimated positions for all active particles

• Particles are colored by overall-quality [0..1] = [red..green]

• Left-click a particle for visualization of re-projection

• Right-click on a particles re-centers 3D view

Particle analysis

• Select particle in position view (left-click)

• “Context Info” frame displays particle information

• Position in 3-space in [mm]
• Re-projection error in [px]
• Match-count
• Minimal baseline angle [rad]
• Overall-Quality

Re-projection describes the “what if” 2D position assuming 
the particle estimation is perfect.
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Visualization

Position – parameters

• Thresholds for validity of particles. Set via Configuration tabs “Positions”.

• 3D particles with properties violating any threshold are excluded from ALL 
visualization modes.

“Re-projection error” : maximum allowed deviation between detected 
(green) and re-projected (white) 2D particle.

“Match-count” : min. number of 2D particles used for estimation. More matches 
result in more stable 3D positions.

“Min baseline angle” : Quality of relative positions of involved lenses. In [rad]
MIN = 0      : Lenses are allowed to lie on a line (instable depth matching)
MAX = π/2 : At least 3 lenses form a right triangle (more stable but less often)

“Min. overall-quality” : minimum quality allowed for valid particles. Relates
observed match count and optimal match count of 2D particles.
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Visualization

Movement – single image

• Visualizes estimated position displacement for all time 
tracked particles from previous to active image

• Colored line segments  red = fast -> blue = slow

Movement – single track / all tracks

• Shows the position history for a single and all particles 
respectively as a curve (= track).

• Segments (= single image displacements) are colored 
by speed as above.

In addition to the particle thresholds, constraints (see next page) to the 
displacements can be applied using the movement Configuration tabs.
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Visualization

Movement – parameters

Thresholds for validity of velocities. Set via Configuration tabs “Movement”.
• In-/Valid  =>  ex-/include from visualization and grid computation

“Max. Velocity” : threshold for particle velocity in [mm/s]
(requires correct “Time Delta” setting in main configuration)

“Velocity Scale” : scale for displayed velocities to improve visibility
(applies to single image and grid visualization)

“Track Index” : select the track to visualize in “Single Track” visualization.

“Min. Track Length” : threshold for minimal number of time matches in tracks to 
visualize. Applies to “Single Track” and “All Tracks” modes.

“Enable Animation” : Replaces continuous track curves by animated virtual particles.
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Result Data Export
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Result Data Export

• Export data to text files (whitespace separated, row major) using the 
“File->Save…” menu buttons

• “Save Tracks” exports all estimated 3D positions in [mm]. In addition the 
image number, the quality information and the according track ID.

• “Save Velocities” exports all local velocities for successive image pairs. 
Velocities are given in [mm/s], providing the algorithm’s “Time Delta” 
parameter is set correctly.

• “Save Grid” exports the regular grid positions and velocities as plain text 
or to vtk file format.

• The used coordinate system is given relative to the camera system in 
[mm]. See next page.
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X

Y

Z

Conventions on coordinate parameterization
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Result Data Export

Save All Tracks provides particle per line information on:

• Image number of particle

• Actual position in [mm]

• Match count

• Re-projection error in pixels

• Maximal baseline angle in radians

• NEW: Overall Quality

• Track ID (same ID for all time indices of “same” particle)

Format:
#image     posX posY posZ #matches     error     angle overall-quality TrackID
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Result Data Export

Save Velocities provides velocity per line information on:

• Image number of reference time  N-1

• Image number of match time  N

• Velocity in [mm/s] at given position

• Position in [mm] (half way between matched particles)

• Number of 2D time matches used for 3D particle time match

• Minimal number of 2D matches of involved 3D particles

• Maximal re-projection error of involved 3D particles

• Minimal baseline angle of involved 3D particles

• NEW: Overall Quality

• Track ID (same ID for all time indices of “same” particle)

Format:
(N-1)  N | velX velY velZ | posX posY posZ | #time-matches #particle-matches | error  angle overall-quality | TrackID
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Result Data Export

Save Grid copies computed grid to plain text (.grid extension) or vtk format
 Use file-extension selector in file dialog to choose format

Text format :
• First line: 3x cell count | 3x cell size in [mm] | 1x dummy 0
• Second line:

 Position [mm] in x/y/z component of top-left-front grid node
 Position [mm] in x/y/z component of bottom-right-back grid node
 1x dummy 0

• Following lines : Grid node position in [mm], velocity in [mm/s] and cell density
 posX posY posZ velX velY velZ density

VTK files :
Are stored in rectlinear grid format, e.g. for import to ParaView. The cells velocity are 
stored in import data “velocity_vectors” array. The number of measurements per cell are 
stored as “density” array.


